frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Destroyer component not firing

edited February 2017 in General
First, thanks for everyone who's been helping me.

Here's my game: https://flowlab.io/game/play/588397

When the capsule's fuel reaches zero (fly it using W, A, and D) I have it set up so it plays an explosion animation and a sound when the bar reaches zero. After the animation is done is fires the destroyer component. See screenshot.

Screen Shot 2017-02-09 at 7.18.55 PM

When you fly the capsule at higher altitudes and it runs out of fuel everything works as expected. But when you fly lower and run out of fuel near the ground the animation and the sound work, but the destroyer no longer does and the object remains. See screencast below.

Tagged:

Comments

  • Try using a timer instead of an animation
  • That works! But I'm also still wondering why the initial logic I had set up didn't. In any event, thanks for your solution.
  • So the animation "done" output would never trigger? Is it possible that the animation was set to loop and so it never completed?
  • Hey @grazer I didn't have it set to loop. I've hooked it back up how it was and it's still happening. You'll see that the component doesn't fire and the ship remains intact.

    Here's a fresh screencast:

Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch