frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Flowlab lag; is it possible? Is it the game, even if everything was working perfectly before?

edited July 2014 in General
I feel like I have wasted too many hours trying to make something rather simple (but taking time to complete). So basically, my game consists of mostly mouse clicks, which is converted to touch on iOS. Here, I will demonstrate the most frustrating cycle in 5 steps:

1) Mouse click triggers are firing off different mouse triggers. I am not stupid, I am 100% positive the objects are different, and I spent hours making sure it is impossible for object 1 to fire off object 2. I even opened up the behavior window for object 2, it's mouse trigger is firing when I click object 1, which does indeed have the mouse trigger as well.
2) Going back to the game browser, and back the actual game. Different objects are emitting when they are not supposed to. And I can click them when I don't want to. Not an issue, let's refresh the page, right?
3) I refreshed the page. Ok, everything's fine (not emitted, rather), let's click object 1, and now object 2...oh joy, object 2 isn't working. Let's open up the window...I am bluntly, clearly, and obviously clicking on object 2 and the mouse trigger is not firing. OK let's refresh the page again!
4) Hm, so object 1 and 2 are working properly! Now I need to click on object 3 or 4...well, I can only click the top parts of the object, but they still work. Let's refresh the page yet again!!! :D
5) Object 1 works...Object 2 works as well, BUT only certain areas! But it still functions properly! Oh joy, now the entire areas for objects 3 and 4 are working! Interesting...I did nothing with the actual objects to deserve this!

And this is why I am about to have an aneurysm. Given these descriptions, is Flowlab lag possible, or is it possibly my object's behaviors?

Comments

  • I don't think this sounds like lag from your description, but it certainly might be a bug. Can you send me a link and tell me the names of the two objects you're talking about? I'll try to reproduce it and see if it's a bug.
  • Ok. I did take some time to figure out some solutions...I'll try to apply these first, and if it doesn't work, then I'll have you give it a shot.
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch