frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Make an animation only play while on the ground?

I'm trying to make my character have a jumping animation, but if i move while in the air, it goes back to the walking/standing animation. Is there any way to make it not show the walking animation while in the air?

https://flowlab.io/game/view/740687

Comments

  • Check “always complete” for the jumping animation
  • Something I mentioned earlier today to @CrimsonBlackGames
    I hope you're using filter extract y speed for jump and fall animations. If you're not, you're doing it wrong. Y up for jump y down for fall, 0 is neutral (no animation). This will override the running animation so you're not running in the air like most games seem to have. I started using this myself. That way there's no jump stopping when you let go of jump.
    Have an extractor detect the y velocity, connect that to two filters. One is greater than 0, the other is less than 0. Greater than 0 plays jump, less than 0 plays jump or fall if you have a fall animation. When you jump, you will play jump animation, then neutral, then fall animation, then land on neutral. This looks the best, and let's you walk normally on ground. If you want walking to only work on the ground, have collision bottom turn on an on off switch, and left/right go in. Have both filters turn off the switch. Jumping will now block walking until you touch something under you. If you're standing on something, left and right play the walk animation.
  • Or just always complete like @CrimsonBlackGames said
  • Always complete becomes a problem if the jump is longer or shorter than the animation, and also cancels out any further animations, like shooting in the air or flying.
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch