frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

New update - optimizations phase II: The Optimizationing

edited May 9 in Announcements
I just deployed another optimizations update.

This update manages to give the engine a pretty significant overall speed boost. This does not include the "pause offscreen objects" setting, since I have decided to forgo that for now and try to just make the engine much faster overall instead of having a setting to make it run faster.

There are no new visible features, but:

1) Nearly all games should run faster in play mode. The more static (no movement or behaviors) objects that your game has, the more of performance boost you can expect (Sorry, Starblast). Some games I've tested have a 50% or more improvement.

2) Switching between play and edit mode has been optimized. For most games this hasn't been an issue, but games with lots of objects have had a pretty serious delay when switching that has been greatly reduced.

This update has some pretty serious internal changes to the engine, and although I've spent a lot of time testing, please let me know if you spot any issues I introduced into your games.

Comments

  • I was hoping for new features :p
  • There seems to be a bug with an object spawning something and destroying itself. When returning to edit mode, either the spawner or the spawned object (maybe both sometimes?) persists, and it can continue accumulating more until you reload the game. Also the game speed can sometimes double when returning from being tabbed out of the game for a while.
  • I'll check this out, thanks. The second issue you mention where the speed is doubled after returning from a tab - is that temporary?
  • edited April 5
    I never verified if it was temporary, but I know it continued at a fast speed for at least 10 seconds once before I reloaded, next time it happens I'll check if it resolves on its own.
  • edited April 6
    Some things are acting up editor wise.
    Also “Sorry, Starblast” cracked me up

    @grazer although now there’s a problem with Starblast 3, note the exhaust emitted when the ship moves- when the ship moves up, the exhaust goes sideways, but it works fine in every other direction.
  • @grazer I don’t think it notifies when you edit a post, but if it does whoops.

    A bug
  • @Wizardry - the issue with spawned objects not getting cleared should be fixed with the latest update tonight. @SnakeInMyHoot also mentioned an issue with things running fast, but I haven;t seen it yet. I'll continue to investigate that one.
  • Hey @grazer in the addition of the bugs I mentioned earlier on this thread- when you max out the window size, non-static objects only render when in the middle of the screen
  • edited April 8
    That's weird @CrimsonBlackGames - it doesn't sound like it's related to this update, but I'll check it out for sure. Thanks for reporting.
  • Might be related to this update because I haven't seen it before, but some of my emitted objects are defaulting to angle 270/up for their first emit. It doesn't always happen, but if it does it only happens once and then they emit the proper angle from then on.
  • @CrimsonBlackGames - I can't find the trail emitter logic in your ship behaviors, where is it?

    Also, I can't reproduce the issue with objects not rendering when the window is maxed out. Is there something else I need to do to make it happen?
  • edited April 10
    Movable and rotation enabled- 100% bounce


    The movement emitter should we somewhere towards the right
  • Even though it’s not on this update, @grazer the “destroy” command for GUI was replaced with “Impulse” and I don’t think its intended. Can you fix that please?
  • @Wizardry & @CrimsonBlackGames - the emit rotation issue has been fixed with an update tonight.

    @CrimsonBlackGames - I don't know what you mean about impulse, what do I need to fix?
  • The GUI behavior node “Destroy” was replaced with “Impulse”
  • Woah that was reported a while ago. It also misses the spawn behavior.
  • edited April 20
    Is there any reason that the emitter default spawns 1 grid block to the left, even with 0 force?
    I would assume emit should default spawn on top of itself. (The button is not solid either.)

    a

    As for what @CrimsonBlackGames means by Impulse

    a
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch