frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Objects losing all their behaviors

It has happened in the past to me once for a trivial object, and occasionally when the game doesn't small save changes for whatever reason, but now it's happened for two of my objects at the same time and has removed everything in them. One object wasn't spawning things correctly and to simplify the problem I made a test level with only it and the player, but it still wasn't spawning some things with proper input. So I exited the editor and refreshed the game to reload everything, I do this a lot. But this time the behaviors in both objects were gone, I checked everything else and they seem fine. The first of these objects is what I was fixing when the problem occured, and the other was something that was being spawned correctly by the first. It's not a big deal and I will just rebuild it, but if this happened to other objects on a much larger game it would suck.

Comments

  • Did you actually close the editor when you tested, or did you just hit the play button... gotta close that editor to save.
  • This only happens to me when:

    1. My connection become weak and I have no Idea so I continue making the game
    or
    2. The object is causing so MUCH LAG (imagine a always and 3 timers repeating forever and emitting and turning off and on and 3 camera behaviours(xD) so It deletes the behaviours causing lag
    or
    3. I'm not logged in

    but @grazer this could be a bug.
    If you send the link or tell the behaviours you had could help track it down
  • @Wizardry - is the object still missing it's behaviors? and if so, have you saved it since then? Maybe post a link and tell me which object it is, and I'll take a look.

    If this happens again, and you are able to, this would be super helpful:

    1) stop working on that game immediately (close the tab)
    2) let me know the game & object that failed (post here, or email me directly)

    That way I can take a look at the object on the server before it has been re-saved, and that may tell me what has happened. Failing to save is a serious issue, so I'd definitely like to get to the bottom of that.
  • edited May 12
    @CrimsonBlackGames
    Is there another way to close the editor without clicking Play? When you click play and the game runs it will say "Open Editor" as if it was closed. It has always worked for me

    @PixelPizza
    I've lost internet many times without it erasing everything in an object before, usually it is just small recent bits I work on inbetween saving.

    @grazer
    I wasn't sure if you could debug game files or look into it, but now that I know for sure I'll just do that next time. I'll try recreating the thing I was trying to do, because even after I remade it I still had the problems for a bit until it was fixed.
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch