frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Emit Isn't Working...

So in my game, the intro can only work in one way; using emit. But it's not working. But in the actual game, the vending machine can still emit nuka colas, you can still shoot from your gun, what's going on with the intro???????

Comments

  • Hey @browngr - post a link to your game when you have an issue. That way, folks that want to help you out don't have to go searching around to try and find it.
  • Ok, I just played it but I don;t see what's wrong. The only thing I see on the "Intro" level is a single large object with an animation. Is that supposed to be emitting something?
  • Yup. So I tried everything. There's multiple different animations to get through, but I tried topping them on top of each other, and so many other things, but none worked and I think this would work if this wasn't happening... So, by placing the objects on top of each other, it would play in the correct way the first time, but then, it would go backwards the next time, leaving you with the look of the last animation until it actually started.... Am I confusing you? Sorry...
  • Hey @browngr - I think I understand now, the emitted objects are probably spawning off screen. Basically since you want to spawn a static object in a particular spot, using a Spawn block will work much better. Change the emits to spawns, and remember that the x/y position should be the center of your game, so x: 512 and y: 240. This should fix your intro up.
  • edited November 9
    It didn't work, @grazer.... Did I do anything wrong?
  • Nope, fixed it. Thanks @grazer! =)
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch