frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

[FIXED] HTML5 bug Cursor is not on the right Square on edit

edited August 16 in Bugs
https://www.loom.com/share/6c904bc0aaf34f5cbfa72fdbcda8774e

this will probably be fixed upon release if you are aware of the problem. im pretty sure you are aware of the problem but im telling you anyway just to be sure.

@grazer

Comments

  • edited July 20
    Yep it happens to me on my lenovo yoga laptop but doesn't happen on any other devices.
  • @grazer I've emailed you about this already.
  • @Dan studios - I cannot play that video for some reason, and I cannot seem to reproduce this problem.

    @Johnny boy, @Dan studios, or anyone else that is seeing this issue - What browser (chrome, firefox, edge?) or operating system (windows 10, mac) are you using?

    If someone can post another video, or post some more details I will be extremely grateful.
  • MywMyw
    edited August 8
    If this is the same issue as mine, the cursor for tiles on the main editing screen is off by 2 down and 3 to the right in tiles (with further experimentation this does change, often times getting further and further from the mouse as you edit behaviors and navigate between menus). It highlights this area and selects it when clicked, while the mouse is a decent ways away from it. At least for me, everything else works, but is a pain to keep accurate in editing. I am using Firefox on Windows 10 with a Dell Laptop (using an actual mouse, not mouse-pad, if that's helpful at all.)
  • Hey @Myw thanks for the info - this will help. If you use a different browser (Chrome, Edge, etc) does it still happen? Also, do you know if you have any settings changed that might affect this, such as the browser zoom being set to 75% or something?
  • MywMyw
    edited August 8
    @grazer I tried it with edge and it seems to still be happening, I don't have chrome so I can't say for sure if it happens there. I have zoom set to default, and the only browser settings I really ever change is regarding privacy. I recall a while back when I first heard of the new structure I used chrome and I had the same problem, though that was some time ago it *was* on a different computer, this one a desktop though I use the same mouse from then today. My mouse is HP if that helps at all too, though I don't see why it would affect it from my end, I may as well say so
  • edited August 8
    @grazer I am using chrome on windows 10. I tried to post a picture but it wouldn’t upload.
  • @Myw @Johnny boy Does the offset change if you resize the browser window?
  • @grazer Yes, It doesn't make it correct though, but when zoomed in it gets closer and in a small window it also gets closer, the smaller the better, but never quite making it to the same tile. Zooming out makes the distance further, too
  • This has happened to me before, but for me it fixes itself when I hit play and then open the editor again
  • Hey, would someone who is encountering this issue try this to see if it's also misaligned, and maybe take a screenshot?

    https://flowlab.io/game/play/1223014?v=html
  • MywMyw
    edited August 8
    @grazer In game it's fine, works perfectly, but in editor its still bugged.

    Thank you for working on a solution, and trying to find the cause and what not!
  • OK, another request for anyone that can assist. If you're encountering this issue, go to the following link (a special debug version of Flowlab)

    https://flowlab.io/game/view/1223014?v=html&debug=true

    Just move the mouse around for a few seconds, then open the console:

    https://developer.mozilla.org/en-US/docs/Tools/Web_Console/Opening_the_Web_Console

    and send me the contents. You can right click->select all and just copy the logs from the developer console and email them to [email protected]

    Thanks in advance if you're able to help
  • @grazer I just sent you an e-mail with the contents as described, I hope it helps!
  • @grazer ? When I try to put the thumbnail it doesent work...
  • I'm sorry if I haven't responded it's because I have been a lot on vacation this summer, but thanks for the help! finally, I can take a break from vacation and make some games!
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch