frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Label bug

The Label will not appear

Comments

  • Hey @Mushroom Productions - maybe post a link, or some more details? This isn't enough info to help track down the problem
  • Hey @Mushroom Productions, did you play or test the game that would result with the alpha = 0.

    @grazer, usually the alpha stays on what it was set in a play or test, so it can be completely invisible in the editor.
  • @grazer when I play the game the label does not show up
  • Please post a link to the game @Mushroom Productions
  • thats the problem. Don't put label here. Put label into blue rectangle (bad english).
  • I looked at this a little bit and as ElecTronIC0 said, you have to drag the text label into the game window (where the background is visible) for it to show up at play time. There is a little something weird going on here though, it seems like the Labels added to "New Type11" and "Super Asperogous" (great name btw) are both without X/Y pins... which I don't understand. Maybe it was because I was viewing someone elses project? If I add a label myself, all the pins are there. @grazer
  • I haven't looked at the game yet, but if the x/y inputs are missing, it just means that particular Label block was added before Label blocks had inputs for x & y.
  • Ah yeah, the Labels are connected to the UI weather or not the object is in the UI layer, so they move with the camera instead of the world.

    And why these labels don't have X and Y's is because theses behaviors are older
    than the update that now has X and Y's. They shouldn't affect the game but its best to use the updated behaviors (new Labels),
  • @JR 01 @grazer @MattKimball @ElecTronIC0 Thanks for the advice. I dont see the new labels any where though. My account for some reason cant upgrade to HTML 5, so maybe that's the problem. How do I change the Labels into the Ui layer.
  • edited November 11
    Labels are always part of the UI.

    If you making new labels and they don't appear with x and y, then it may need your account to upgrade to HTML.

    Go to "my games" and see if an alert come up to upgrade to HTML...
  • Hey @Mushroom Productions - I just upgraded your account to HTML5. It seemed to work fine, but let me know if you have any problems with it, or if that wasn't what you wanted.
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch