Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Buglist - July 2018

edited September 2018 in Bugs
To help organize a checklist, I will be making a list of confirmed and unconfirmed bugs. Please feel free to test these yourself, and contribute your own bugs to the list.

Thank you.

A strike means that grazer has also confirmed the bug, and has been fixed.
(These bugs have been tested several times by at least a few members, or by myself, and do exist.)

[x] is a link to the topic or an image source.

• Destroyer was replaced with Impulse on GUI layer Components section [x]
• Emitter emits objects 1 grid space to the left, instead of on top, even with 0 force [x]
• Raycast cannot see past non-solid objects, cannot detect non-solid objects, and needs an optional passive checkmark to see past solid objects [x]
• Flip does not work when rotation is enabled [x]
• Exported games experience intense lag (Tested myself on Windows Exporter) [x]

(These bugs are not confirmed nor unconfirmed, but have been tested by several people in the community, and likely do exist.)

(These bugs have not yet been tested by either grazer nor I.)

(These bugs have been shown to not exist for others, or could not be recreated, and may be a result of the game itself having bad wiring.)


If you have any bugs, comment them below. I will add them to the list.

Here's a build of a simple Bug Tester engine. You can clone it and use it yourself.
Directional Keys
(Use to check if your buttons are being pressed right, if something they do is not working.)
Up = 1 ; Right = 2 ; Left = 4 ; Down = 8
(Shows a collision marker for 1 second. Use to determine if you are actually touching an object.)
Bottom = 1 ; Right = 100 ; Left = 10 ; Up = 1000
X/Y Velocity
(Use to check your movement, jump, or fall speed.)
-Left +Right ; -Up +Down

Use Spacebar to toggle various testing modes

Bug Tester


  • edited April 2018
    Added [x] hyperlink citations for source of bug or image descriptions in this buglist.
    I figured it will save @grazer some time and list space, instead of loading the images here.
  • I'm having a problem where if a entity is bigger than a single tile it deletes every tile except the top left tile when i refresh the page
  • Make sure you play the game before you refresh, as this triggers a save. If you enlarge the tile and then refreshing before hitting ok or something, it won’t save and therefor won’t keep the enlargement.

    Instead of refreshing, just load the level you’re already in.
  • I deleted a object so I could have space for a different object but it still says sorry you used up all your objects
  • Everytime I play this one game I created, it just starts blinking! I dunno how though...
  • Sounds like you may have an object restarting the game immediately when it starts. This can happen for example if you add a "Dangerous" bundle to a moveable object, and it restarts the game as soon as it touches the ground.
  • Also - the Destroyer button issue has been fixed in the latest update
  • Hi, I seem to be having a problem with exporting to windows (android works fine). Recently every time I try it just seems to be building the game forever - last time it still hadn't finished after four days. I've tried cloning the game/deleting the old one but that didn't do anything either - is there anything known that might be causing this to happen?
  • The queue sometimes get clogged, sometimes because the server is handling too many at a time, but no other reason is known- at least for me...
  • Hey @IgorsBrain - thanks for reporting it, I'll check it out today and make sure the queue is up and running.
  • @grazer I'm having the same problem too! <3
  • @IgorsBrain and @AddoPlayz - the windows queue is finally empty, so all builds should be complete. Sorry about that - the queue was *really* backed up with games.

    The good news is that I made some changes to the windows app export, so it should complete a lot faster now (about 5 to 10 minutes instead of an hour).
  • Hey @Grazer, that's fantastic - thank you! :) Personally I'm just glad it wasn't because of something I broke!! That's awesome news about the reduced export times as well, thank you for looking into this :)
  • I'm a bit late... but thanks @grazer :)
  • edited June 2018
    i have some problems recently with colision/proximity targets

    if i set up a collision/proximity trigger to detect an object, say "Banana", sometimes it will automatically assign one object name in specific like for example "Object 239" to detect instead of detecting any "Banana". deleting the trigger and remaking it, i'll find this same "Object 239" is there to detect even if i don't select anything or try unselecting it. i usually have to delete the trigger and refresh the game for it to stop doing this
  • Hey @Wizardry - you're saying that you select no object name (just a type) and the editor chooses an object for you? And then after that you cannot unselect it?

    Does this happen a lot, or is it difficult to reproduce?
  • Is Object 239 even the banana? I've had something similar in the past. I might know what you're talking about, but I wouldn't know how to reproduce it. Can you do a video or gif example for grazer?
  • edited June 2018
    Is Object 239 even the banana? I've had something similar in the past. I might know what you're talking about, but I wouldn't know how to reproduce it. Can you do a video or gif example for grazer?
    Those are just example names, 99% of the time I never specify object numbers so when ANY specific object number is selected there it's usually this bug if it remains selected after deletion. I learned to fix it with a workaround where you delete it and refresh the page. Today when it last occured I tried cloning the game (to provide a working example of the bug to show) but in the clone the problem went away, and if someone else loaded the game it probably would work fine since that's how my workaround fixes it by reloading the page. So to provide proof I'll just take video next time it occurs
    Hey @Wizardry - you're saying that you select no object name (just a type) and the editor chooses an object for you? And then after that you cannot unselect it?

    Does this happen a lot, or is it difficult to reproduce?
    Yes that's what I'm saying, and after deleting/remaking the trigger/reselecting the object type it automatically has that specific object selected still. It doesn't happen often, maybe ten times I've seen it, but today I had it happen twice for different things. I don't know what causes it or how to reproduce it.

    Kind of related but I've noticed this for a while, for example you have extractors getting data about something, and you choose an object type like "person", and then specify "object 372" (or just the object type alone). When you clone the game, this information is lost and you must re-enter the obect type and object number.
  • edited June 2018
    I clone some backround blocks and place them in the game, I edit the other level, come back to the 1st level and the cloned backround is not there Edit: turns out there was another backround object blocking the other ones its all good know
  • edited June 2018
    There's a few tile bugs, I just choose to ignore them. One of them that gets in the way the most, is when you upload a file, and it's bigger than 32x32, once you save the object, and exit the behaviors, the object offsets itself somewhere, and freezes, and you can't move that object until you refresh the page. Occasionally, you will get a ghost clone, just a random clone somewhere when you do multiple clones at a time, and you won't see it until you refresh the page. You'll just have to delete it once you do. Don't really know where it comes from. The last tile problem that bothers me, but I ignore it, layers don't click based on layers. They never have, they tend to choose whatever the largest object is at random. If you have a massive rectangle, and put a smaller rectangle or square on top of it, trying to click anything will just grab the largest rectangle, even if it is on the farthest back layer. Just some bugs that have been around for years, it really just doesn't bother me anymore, but it would be nice if they got fixed, but they don't need to.
  • A bug I think a lot of people have noticed is the copy and paste error. For instance, when I want to copy a URL for Mp3 files, when I try pasting it in the box, it will not paste for any of my games. Thank goodness for the new upload feature!
  • I never have that problem @Cap. Red Crab
    I just pasted a link to music in my game a couple days ago.
  • Won't build Android app? It just keeps saying: building android app. For over 8 hours now.
    Tried it many times.
  • Hey @remkowh - Sorry about that. The build server was killed by an electrical storm this weekend, and is being replaced. The build queue should be up and running again tonight.
  • Ok thanks. Nice to know.
  • edited July 2018
    @grazer and that electrical storm killed a tree which in turn killed a few boards on our fence... lol
  • edited July 2018
    Why is the "pause objects off-screen" feature gone? @grazer

    Awakening is lagging a lot even with a few objects in the level.
    My internet is working fine and my new PC is really good. Any idea of what is causing it?

    Also, Is there a way to download the sounds of the flowlab library? I would like to edit some to make loops
Sign In or Register to comment.

| make games in your browser
@ 2017, All rights reserved.

Contact us

Get In Touch