frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Alert Bug on the Last Level

edited May 11 in Bugs
If you go to the credits of DRIVE;
when you press an object with the alert, you cannot click to get out of it.
This is only in the last level (or credits), all alerts works perfectly fine in the other levels.

I made the game accessible even without needing to click out of the alert, but this is rather annoying.
I don't know if this is cause by pausing the game, stopping an ease function, being on the last level of a free edition, or for any other reason.
If the alert works, then it could be that it stops working after selecting it once.
If you can get it to work consistently, then let me know.

I set the alerts up to described in a way that you wouldn't need to click out. So if this isn't resolved, the game perfectly works. Though, you won't be able to resume the credits without reloading the level.
My only workaround would be to create an interface object to create a button, but I'm already on my object limit. I would like to release DRIVE to the app-store this month, so I just want to clear as much as the bugs as I can (and before getting an Indie account).

Link to DRIVE: http://www.flowlab.io/game/view/938307

Comments

  • So that's why you're having so many people review it!
  • Mostly because I plan on adding it to the app store. I wanted to get opinions and find bugs.

    This bug is old though and I have built around it. I just want to finish anything I left unfinished such as features and old bugs.
    I want to get this game out next month.
  • edited May 24
    @grazer, do you know why this is happening only on the last level?
  • edited May 24
    I don't know how but this is now fixed in both versions...
    I didn't change or add anything, the alerts just started working.

    It didn't work for the second game at first; but after refreshing the game a few times, it's now working.
    Was there an update recently? or just a random fix?
  • edited May 24
    I did just deploy an update, but only for the HTML5 version. The Flash version has not been updated in quite a long time.
  • @grazer
    I'm not sure about HTML, but I use the flash version. (I need to update my bookmarks)
    Anyway, the only thing I knew about this bug before is that it was caused by the "Word" object that the credits are stored in. When I would delete the object, the alerts would close properly.
    After the update though, both versions started working.

    I wasn't sure if it was because I was pausing during an ease or something;
    but if it was from the effects of this update,
    I think it would be the timers by the description of your patch notes.
  • Hrm, that's odd. I doubt that updating the HTML5 version could have affected the Flash version in any way, so it must have been something else.

    Using the Flash version is still fine for now, as that's still the "official" one for now. I'll start changing the links on the site to the new version once it has had a little bit more testing.
  • On a side note: Another thing I notice when I was testing around the second game, the first game was running smoother overall with less lag in its editor too. After a few refreshes, the second game was running just a smooth and fixed.

    I tested the second game just shortly after I noticed the first game was working.
  • Thanks for update Grazer, whether this was effected to it or not, updates to Flowlab is always a better experience! I'm just glad the alerts to this level works again, no one could continue the credits IF one of the icons were pressed.
  • Hey @grazer, this started happening again but I have found the problem!
    It's the layering of the GUI behaviors. Some of most of the words are in front of the alert that is preventing you from hitting the button.

    I made a copy of the credits object and tried a few things.
    I have 13 labels in front of the alert and I deleted about 7 before the alert started working again.
    After a few more tries, I just moved all the labels out of the way of the alert.
    Sure enough, the alerts worked with all the labels on the screen. Just some are covering the alert.

    I'm not sure but I think this was fixed in HTML5
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch