frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

HTML5 Bug

edited August 17 in Bugs
for some reason when a sound behavior is played it takes time for it to play meaning when you, for example, die in a game the music won't play immediately when you die. an example of that would be my (unfinished) game. and the music that is supposed to play at the start of the game won't start after a few seconds. let me know if it only happens to me. this did not happen before i upgraded to Html5
link: https://flowlab.io/game/play/1226322

@grazer

Comments

  • I'll take a look, but it sounds like this is due to the sound downloading/buffering the first time it is played. If it is a particularly large sound file this can take even longer.
  • oh ok, but this didn't happen before the Html5 upgrade. but I have no idea about if it affects the buffering or not.
  • edited August 17
    @Dan studios, this is somewhat common even before HTML5.
    Like Grazer said, its because of how Flowlab loads music.

    What Flowlab does is load the entire sound file before actually playing it.
    On the site, it loads whenever the sound is activated. If your browser hasn't loaded the sound recently, then it could take a little to a bit of time before it starts playing. This could also start a bug for going on a another level before its played in which you cant turn it off until its activated again.

    On exports, usually what happens is the game freezes until the music is loaded when played.
    I found a way around this by just playing all sounds in the game on the first loading screen. Then the game will play as normal.
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch