frame

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Register

Um, there's something wrong with this

I'm not sure if this is due to the new message update, but my game, A-Box, has suffered from something. In the sections of the game with the buttons and platforms, for some reason not all the platforms will show up, and seems to come out completely random in the game.
-
Here's A-Box: https://flowlab.io/game/play/1148793
-
Thanks to anyone who can figure this out! @grazer

Comments

  • Hey @rcreger - it does appear that this is due to the updated message behavior, unfortunately.

    I see at least one problem in the Button object: When you click the button, it sends the message to the empty blocks to create solid blocks, and then follows that up by sending a message to all the new solid blocks to delete themselves.

    This used to work because there was a delay in the messages, so the solid blocks wouldn't exist yet when then message to delete them was sent. Now the message sending is much faster, so they will get created and then deleted immediately, before you even see them.

    Does this make sense?

    There may be other issues as well, but that's the first one I saw.



  • Thanks for [email protected] , I'm not so keen on how FlowLab works as much as I used to be - even then I wasn't too up there. If there's a way to fix these, it'd probably be best with the screenshot as I am a visual learner. Thank you!
  • I am having a lot of this in mine as well. I don't see anything wrong with my flow configuration that I am aware of. Do you know of a work around or if there are any solutions in progress? It is inconsistent in which platforms are effected as well.
  • edited February 15
    @HandzHW - I just deployed a fox for your issue.

    @rcreger the following illustrates what I mean:

    imagescreenshot

    This used to work because there was a delay in message processing, so the newly spawned solid blocks didn't exist yet when the second (destroy) messages were sent. That delay has been removed, and now messages are delivered instantly.



  • Thank you @grazer , but I'm still not completely sure what I am to do with the issue?
  • How about using a Toggle Switch to make sure that you only send one message at a time?

    Something like this:

    screenshot
  • Thanks @grazer , it helped! Though it is having issues reappearing, but I'm going to try JR 01's example after school. Thank you for responding!
  • @rcreger Glad your game is working, really enjoyed playing A-Box! It's a game that can be short hard, and still be fantastic. Hope the game holds well! None of mine ever do, and hope you make a sequel.
Sign In or Register to comment.

flowlab.io

| make games in your browser
@ 2017 Flowlab.io, All rights reserved.

Contact us

Get In Touch